Tin tặc lợi dụng lỗ hổng để tấn công các trang WordPress

  • 26/05/2020
  • 14:35
(Mic.gov.vn) –  Một lỗ hổng đã được xử lý gần đây trong plugin đánh giá sản phẩm (WP Product Review Lite) WordPress có thể bị tin tặc lợi dụng để tấn công các trang web.
WP Product Review Lite được thiết kế để tạo ra những đánh giá (review) sản phẩm trên các trang web WordPress. Nó hỗ trợ việc tạo ra một widget đánh giá những sản phẩm hàng đầu cho phép kiếm tiền thông qua việc nút “buy now” trong các bài đăng. Plugin đã có hơn 40.000 cài đặt.

Widget là một tiện ích quan trọng trong mọi giao diện WordPress, đóng vai trò chỉnh sửa, cấu hình giao diện và quyết định các hiển thị trong thanh slidebar của một trang WordPress cơ bản.
Tin tặc lợi dụng lỗ hổng để tấn công các trang WordPress
Tuần trước, nhóm các nhà phát triển plugin đã xử lý một lỗ hổng XSS (Cross-Site Scripting – Kịch bản chéo trang), có thể bị khai thác để cấy mã vào tất cả các trang sản phẩm của WordPress.
Về vấn đề này, các nhà nghiên cứu bảo mật giải thích rằng, mặc dù tất cả dữ liệu đầu vào của người dùng đã được “làm sạch”, một trong những tính năng của WordPress được sử dụng có thể bị bỏ qua nếu tin tặc thiết lập lại tham số bên trong thuộc tính HTML.
Các nhà nghiên cứu cho biết: “Khi khai thác được lỗ hổng, tin tặc có thể cấy các tập lệnh độc hại vào tất cả các sản phẩm của trang“.
Theo cảnh báo của công ty bảo mật Sucuri, có thể khởi động một cuộc tấn công mà không cần xác thực, nghĩa là các tác nhân đe dọa có thể tự động tấn công. Điều này khiến cho tội phạm mạng dễ dàng thiết lập các tấn công nhằm một số lượng lớn các trang web có chứa lỗ hổng.
Các nhà nghiên cứu của Sucuri lưu ý rằng: “Số lượng những cài đặt hoạt động, khai thác dễ dàng và những ảnh hưởng của cuộc tấn công là những thứ khiến cho lỗ hổng trở nên đặc biệt nguy hiểm“.
Sucuri đã báo cáo lỗ hổng vào ngày 13/5 và phát hành bản vá vào ngày hôm sau với phiên bản WP Product Review Lite 3.7.6
Mặc dù không quan sát thấy có nỗ lực khai thác nào, các nhà nghiên cứu bảo mật khuyến nghị các quản trị viên web nên nâng cấp lên phiên bản đã được vá càng sớm càng tốt, vì những phiên bản cũ của plugin vẫn dễ bị tấn công và có nguy cơ bị xâm phạm.

theo ictvietnam.vn

  • Nguồn tin: